Card payment unavailable
Incident Report for SumUp POS
Postmortem

A development copy of the Goodeats frontend codebase containing a bug affecting Stripe card payments was deployed accidentally. A git pre-commit hook which builds the project was not executed due to a configuration issue, leading to the deployment of an outdated development build rather than a production build of the up-to-date codebase.

This was resolved by deploying a production build of the current version.

Posted Mar 19, 2021 - 13:53 UTC

Resolved
Card payments utilizing manual or saved card entry for Stripe payments were failing. Apple/Google pay payments were unaffected.
Posted Mar 19, 2021 - 13:49 UTC
This incident affected: Goodeats.