SumUp POS - Card payment unavailable – Incident details

Card payment unavailable

Resolved
Partial outage
Started about 4 years agoLasted less than a minute

Affected

Goodeats

Operational from 1:49 PM to 1:49 PM

Updates
  • Update
    Update

    A development copy of the Goodeats frontend codebase containing a bug affecting Stripe card payments was deployed accidentally. A git pre-commit hook which builds the project was not executed due to a configuration issue, leading to the deployment of an outdated development build rather than a production build of the up-to-date codebase. This was resolved by deploying a production build of the current version.

  • Resolved
    Resolved

    Card payments utilizing manual or saved card entry for Stripe payments were failing. Apple/Google pay payments were unaffected.